I do not receive emails from Skillibrium
Problem:
I signed up for Skillibrium, however I did not receive the email after the registration process or I am invited to join Skillibrium, however I did not receive any email from Skillibrium in my mailbox.
Cause
Your organization utilizes Microsoft 365, and a quarantine policy has been enabled. If this is not the case, please refer to the end of this article for alternative solutions.
Solution
- Login to Microsoft 365 admin center > click Security > click Policies & rules > select Threat policies
- Under Policies, select Anti-spam policies.
- Click the Anti-spam inbound policy (Default) > Scroll down to the bottom and click Edit allowed and blocked senders and domains.
- Click Allow domains under Domains.
- Under Manage allowed domains, click Add domains.
- Enter the domain name in the field, and then click the field created below the domain name.
- Click Close.
- https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/quarantine-about?view=o365-worldwide
- https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/quarantine-end-user?view=o365-worldwide&source=recommendations
- https://support.smtp2go.com/hc/en-gb/articles/360000471954-Allowlisting-IP-Addresses-With-Microsoft-365
If your organization does not utilize Microsoft 365 and you are not receiving emails from Skillibrium, please consider the following steps instead:
- Double-check the email address used to sign up for Skillibrium or the email address of the intended recipient to ensure accuracy.
- Check your junk or spam folders in your email client. Sometimes, legitimate emails can be mistakenly marked as spam by email filters.
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