I do not receive emails from Skillibrium

I do not receive emails from Skillibrium

Problem:

I signed up for Skillibrium, however I did not receive the email after the registration process or I am invited to join Skillibrium, however I did not receive any email from Skillibrium in my mailbox.

Cause

Your organization utilizes Microsoft 365 and a quarantine policy has been enabled. If this is not the case, please refer to the end of this article for alternative solutions.

Solution

To resolve this issue, you will need to release the quarantined emails and add skillibrium.com to the whitelist. 

Follow the steps below as seen in Microsoft Support article to whitelist Skillibrium: 
  1. Login to Microsoft 365 admin center > click Security > click Policies & rules > select Threat policies 
  2. Under Policies, select Anti-spam policies.
  3. Click the Anti-spam inbound policy (Default) > Scroll down to the bottom and click Edit allowed and blocked senders and domains.
  4. Click Allow domains under Domains.
  5. Under Manage allowed domains, click Add domains. 
  6. Enter the domain name in the field, and then click the field created below the domain name.
  7. Click Close.

More Information

  1. https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/quarantine-about?view=o365-worldwide
  2. https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/quarantine-end-user?view=o365-worldwide&source=recommendations

If your organization does not utilize Microsoft 365 and you are not receiving emails from Skillibrium, please consider the following steps instead:
  1. Double-check the email address used to sign up for Skillibrium or the email address of the intended recipient to ensure accuracy.
  2. Check your junk or spam folders in your email client. Sometimes, legitimate emails can be mistakenly marked as spam by email filters.
If these solutions do not help, please raise a support ticket
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